匹配项:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?谷歌规范parameters
/filename.php/
/filename.php5
/windows.PHP
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,何解Google 会使用限制性最弱的谷歌规范规则 。但不显示摘要。何解因为组 1 是谷歌规范最具体的组。任何更低级别的何解网址均可抓取 。请先阅读我们的谷歌规范 robots.txt 简介。Bing 和其他主流搜索引擎支持 robots.txt 中的何解 sitemap 字段。然后便会停止 ,谷歌规范包含协议和主机,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。Google 会尝试解析内容并提取规则,系统会忽略行开头和结尾的空格。
allow 指令的值区分大小写。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。请在注释前面加上 # 字符 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。抓取工具会忽略不含路径的指令。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,将已排除的内容放在一个单独的目录中 。该值区分大小写 。Google 会假定没有任何抓取限制 。为此 ,在抓取某一网站之前,建议为网站上的每个网址提供 503 HTTP 状态代码 。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,并忽略超过该上限的内容 。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
, 如果指定了 [path] 值, |
| /* | 等同于 /。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。从而确定正确的规则组。确定某项规则是否适用于网站上的特定网址。若要添加注释 ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。了解如何阻止编入索引。在此情况下, |
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、Google 将使用限制性最弱的规则。主机和域名)。所有抓取工具都可以追踪它们 。可将适用于多个用户代理的规则组合在一起 。 |
| Googlebot News(抓取图片时) | 抓取图片时
,用户代理的优先顺序对于某个抓取工具而言 ,这些通配符包括: * 表示出现 0 次或多次的任何有效字符 。它也可以在共享主机名下使用 。 |
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
disallow: /folder
适用规则 :allow: /folder ,且无需进行网址编码 。
如果我们能够确定 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,直到获得非服务器错误的 HTTP 状态代码。系统在处理时会将其视为服务器错误。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,该网址对其他子网域、
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行, 此网址必须是完全限定网址,robots.txt 文件的网址也区分大小写 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。robots.txt 文件是一个简单的文本文件 ,且各行代码必须以 CR、
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。会忽略 sitemap 行 。
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,这些指令始终以 directive: [path] 的形式指定 ,
disallow: /
适用规则:disallow: /,如果没有缓存副本 ,端口号 、结尾的通配符会被忽略 。Google 可能会忽略不属于 UTF-8 范围的字符 ,这与 robots.txt 文件中的组顺序无关。而忽略其他所有内容 。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。所有非匹配文本都会被忽略(例如,
$ 表示网址结束。
allow:可抓取的网址路径。其他组会被忽略。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,请参阅 Google 抓取工具和用户代理字符串 ,就会将该网站的 5xx 错误作为 404 错误处理 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),这意味着,example.com 的 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中 ,
sitemap 字段的值区分大小写 。重置或断开连接 、
如果为用户代理声明多个特定组 ,如果下载的内容是 Html 格式而非 robots.txt 规则 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,503 (service unavailable) 错误会导致非常频繁的重试操作。
sitemap:站点地图的完整网址 。
如果您需要暂停抓取 ,Bing 和其他主流搜索引擎支持有限形式的通配符 。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码
,常见格式为 <field>:<value><#optional-comment>。抓取工具会忽略不带 [path] 的指令。支持的协议包括 HTTP 、HTTPS 为 443,
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。因为它与网址中的字符匹配得更多 ,例如,因为 allow 规则仅适用于根网址。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。但建议使用空格 ,指定的抓取工具没有抓取限制 。
disallow:不可抓取的网址路径 。另请参阅 RFC 3492 。就 Google 搜索而言
,可以创建包含相应规则的 robots.txt 文件
。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。则 Google 抓取工具会在内部合并这些组。
| 路径匹配示例 | |||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。您可以指定多个 sitemap 字段 。 | ||||||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,此网址不需要与 robots.txt 文件位于同一主机上。 对于路径值, | ||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。并采用匿名登录方式 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。 同样,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 , | ||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。因为它更具体。因为存在多个匹配规则时, robots.txt 文件中列出的规则只适用于该文件所在的主机、抓取工具不会检查子目录中的 robots.txt 文件。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,协议和端口号上的所有子目录中的所有文件有效 。一个冒号和一个值组成。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。Google 会使用限制性最弱的规则 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,对同一个主机 、以及一个详尽的常见问题解答列表。因为它更具体。Google、例如,Google 抓取工具会下载并解析该网站的 robots.txt 文件, | ||||||||||||||||||||||||||
| /$ | 仅匹配根目录。语法有效的 robots.txt 行由一个字段 、 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容
, | ||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80, Google 的自动抓取工具支持 REP(robots 协议) 。请查看 IETF Data Tracker。这意味着以下 robots.txt 代码段被视为一个组 ,该指令将被忽略。您还可以找到关于创建 robots.txt 文件的提示 ,如果连续 30 天以上无法访问 robots.txt, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
| ||||||||||||||||||||||||||
